Friday, 8 August 2014

Skype 5.5, 5.9 fix for login issue after 31.07.2014

Seems like it was really more simple then we think.

So,

to fix skype login in version 5.5 deobsfucated, change unicode string 0/5.5.0.124 to 0/6.9.0.106 at offset 0xDAFCB8 in binary.

To turn off detailed logging, change bytes "0F 84" to "90 E9" at offset 0x10CEA91.
-- Vilko

So, just download files from this piratebay release:
magnet:?xt=urn:btih:FKJ5GA6OKOFB6WEU7EYIMJKYG7GMH3X7
and patch them.

P.S. Version "6.9.0.106" may not work, so better patch into something with >= 6.14.x.x, for example: "6.18.0.105".

Its fix for this news.

135 comments:

  1. But how to patch? Dunno lol

    ReplyDelete
  2. magnet:?xt=urn:btih:8003250D6A73DC766B5937C3DA28755FEE67D9E7
    patched version

    ReplyDelete
  3. Changing 0/5.5.0.124 to 0/6.9.0.106 have no effect anymore. So sad that microsoft watching this blog too :(

    ReplyDelete
  4. Everything works fine, just checked.
    May be you change some wrong string? (I change ver to 6.18.0.105)

    ReplyDelete
  5. Thanks, with 6.18.0.105 it works great! I just used 6.9.0.106 from the main post, it's looks already old.

    ReplyDelete
  6. Someone taking credit for a patch that I gave in the other thread, but my comment was never approved.

    Skype 5.5.0.124:
    Search for once - 35 00 2E 00 39 00 2E 00 36 00 36 00 2E 00 31 00 31 00 34
    Replace with - 36 00 2E 00 31 00 36 00 2E 00 30 00 2E 00 31 00 30 00 35

    Skype 5.9.66.114:
    Search for once - 35 00 2E 00 35 00 2E 00 30 00 2E 00 31 00 32 00 34
    Replace with - 36 00 2E 00 31 00 36 00 2E 00 30 00 2E 00 31 00 30

    ReplyDelete
  7. where can i find to replace unicode string

    ReplyDelete
  8. New binaries with fixed login.

    skype55_patched.exe (32,27 MB)
    magnet:?xt=urn:btih:8003250D6A73DC766B5937C3DA28755FEE67D9E7

    skype59_patched.exe (32,27 MB)
    magnet:?xt=urn:btih:2B2BA7F265A95FC117EEBC8CCCA98C48DBE139EE

    ReplyDelete
    Replies
    1. 5.5 crashed me twice. I am trying 5.9. Both seem to work, but my computer suddenly re-starting is not the best of signs.

      Delete
    2. I guess its not only ident string change patch, the original skype 5.5 is 16 MBytes but the patched release is 33 MBytes, so there something inside

      Delete
    3. Your laziness and stupidity are inside.
      Learn the theory then post your suspicions :)
      This version of Skype is DEOBFUSCATED, so this mean the original is OBFUSCATED - i.e. encrypted/encoded by some complicated method. In case of Skype (as in most others) it is also compressed, so it occupies less space than unpacked and deobfuscated version.
      Wanna be safe-n-cool guys?
      Research by yourself! This is the only way to be as safe as possible for you. Another way is to earn other ppl to write your own "Skype". Sure you've not enough of shit-o-money or anything else to offer in xchg.

      Delete
    4. Can I get deobfuscated skype 6.10 or later ?
      These version binaries crash with runtime error on my environment , so I want to debug them and make patching.

      Delete
    5. try to ask on skypeopensource@conference.jabber.ru :)

      Delete
    6. Skype 4.2 deobsfucated, patched for login:

      skype42i_patched.exe
      magnet:?xt=urn:btih:427TQ5VZHET36B7A5HZMDRVCCKI6BLA3

      Delete
    7. Thanks, but this link doesn't seem to work.. Is it working?
      I am interested in version 4.2.

      Delete
    8. Its magnet link for torrent client. Yes, its working.

      Delete
    9. skype42i_patched.exe above is working fine. Thank you. However, I noticed that every time I start Skype, it creates two debug text files in the folder. How can I avoid having these text files?

      Delete
    10. The solution was below. I changed bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF, and debug files are gone.
      Thank you

      Delete
    11. If you look further down the page you'll see the answer:-

      Quote

      to turn off logger in 4.2 - change bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF

      Unquote

      You just need a simple hex editor to do it.

      Delete
    12. Is there a patch for the 4.2 business version please?

      Delete
    13. I too would like the business version if it's not too much trouble. Thank you.

      Delete
    14. 4.2 patched doesn't connect :(

      Delete
    15. 4.2 is working fine for me so try a complete uninstall of skype and then a new install with the patched .exe and see if that fixes it.

      Delete
  9. how to change unicode string anyonee can help mee ?

    ReplyDelete
    Replies
    1. just download already patched ver

      Delete
  10. Скачал а дальше что делать

    ReplyDelete
  11. Downloaded and then what to do

    ReplyDelete
    Replies
    1. Ну запускать же, запускать...

      Delete
  12. А что про linux версии???
    LINUX FIXED??

    ReplyDelete
    Replies
    1. Какая версия линух-скайпа наиболее актуальна/адекватна? какую имеет смысл патчить?

      Delete
    2. 2.2.0.35, 4.2.0.13

      Delete
  13. 2.1.0.47 под Linux тоже вменяемая

    ReplyDelete
  14. Please, where can I download file? Можете дать ссылку на:
    skype55_patched.exe (32,27 MB)
    magnet:?xt=urn:btih:8003250D6A73DC766B5937C3DA28755FEE67D9E7

    ReplyDelete
    Replies
    1. А чем не устраивает написанная в вашем-же сообщении ссылка?

      Delete
    2. Copy this magnet link to your favorite torrent (utorrent, for example) client. Then, it will start download. That's all.

      Delete
    3. Прошу прощения не поняла что это торрент.
      skypeopensource, thank you for the explanation.

      Delete
  15. Can I have only exe file from 5.9 package? I have own portable build with history etc, so all I want is working executable.

    ReplyDelete
  16. Is there any way to make linux runtime of SkypeKit 4.5 work?

    ReplyDelete
    Replies
    1. You have linux skypekit 4.5? I guess last version for linux was 3.x

      Delete
    2. There is no deobfuscated version of linux SkypeKit 4.x, but there is a linux version in the original 4.5 sdk:
      # ./linux-x86-skypekit
      SkypeRuntime Copyright (C) 2003-2012 Skype Technologies S.A.
      SkypeRuntime Version: 4.5.0.105/linux-x86-skypekit_4.5.0.105_2389348
      Proprietary and confidential, do not share this application.

      Delete
    3. I can unpack/deobsfucate it, if u share it somehow...

      Delete
    4. I am not sure whether it has any private information or not. It probably does, because trillian's version has other number at the end of the version (after the underscore). I don't want to share it with everybody, I can only send it via e-mail.

      Delete
    5. Hm, "original 4.5 sdk" is it was public version or just private?

      Delete
    6. It is the last version that was available to download on the developer website. I just can't remember if the runtimes were the same for everybody or they were generated for each key pair like before. It was almost two years ago, if I remember correctly. As I said, I can send the runtimes, but I don't want to make unmodifined version of them public. By "unmodified" I mean obfuscated or deobfuscated runtime with the version number unpatched. I think patching it to skype's version number like you did before would be okay.

      Delete
    7. Ok, can you send it to skypeopensource?

      Delete
  17. хочу поддержать в тестировании этот проэкт, с кем контактировать?

    ReplyDelete
    Replies
    1. Начните с изучения этих постов:

      http://skype-open-source.blogspot.ru/2011/07/great-skype-testing-day.html

      http://skype-open-source.blogspot.ru/2011/06/some-words-about-how-to-test-this.html

      Delete
  18. It's great that these deobfuscated versions exist and it's a shame that they can't be shared here, but why is there no helpful tutorial on unpacking Skype? I'd love the 4.2.0.187 version to work again but nobody has talked about how they've unpacked Skype.

    ReplyDelete
  19. Do anyone have patched-for-login or deobfuscate version of Skype 4.2 ? Please, provide the link here?

    ReplyDelete
    Replies
    1. I tried patched Skype 3.8 but It was refuced from server.
      And after login Skype 5.x, Skype 3.8 and 4.2 can not connect, so I think the reason comes from protocol version.

      Delete
    2. Skype 4.2 deobsfucated, patched for login: http://webfile.ru/538f1d18832921cecc1cfaccfb0afbad

      Delete
    3. This looks legit. Things are exposed the same as Skype 5.5 and 5.9 and I can see that the version string was changed to 6.18.0.106.

      My question is how did you deobsfucate it though? A tutorial posted to pastebin would be appreciated.

      Delete
    4. you know assembler well? you know PE file format?
      Without such skills, you cannot unpack/unprotect skype.exe, even if somebody shows you how to do it.

      Delete
    5. I know the basics. I've not worked with either of them much, but I can follow a guide easily enough.

      Delete
    6. I use assembler and I know PE file format very well as I created PE file restructure tool.

      I tried to unprotect Skype.exe before and I successed to disassemble unpacked code but fail to create the executable unpacked file

      I want to know how easier way to get unprotected binary.:)

      Delete
    7. BlackWingCat, blog is not usefull place to discuss about debugging, contact me on jabber conf, addr above :) (or leave some contact addr)

      Delete
    8. Hey! everybody ask, how to unpack, but I cant see anybody on skypeopensource@conference.jabber.ru.

      Delete
  20. But will this let me use Skype in Trillian without having Skype open?

    ReplyDelete
    Replies
    1. No. You need a deobfuscated version of the executable and nobody has released one.

      Delete
  21. Skype 4.2 deobsfucated, patched for login:

    skype42i_patched.exe
    magnet:?xt=urn:btih:427TQ5VZHET36B7A5HZMDRVCCKI6BLA3

    ReplyDelete
  22. For linux users Debian package Skype 4.2.0.13:
    http://www.datafilehost.com/d/6bbdc14c

    Available + 4 more squashfs files with the same Skype version for different linux as magnet link:
    magnet:?xt=urn:btih:627967e75b1d81b59ea5ce163858ab7726e36dcf&dn=skype-4.2.0.13&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Fopen.demonii.com%3A1337

    More information for linux old skype wprkarownds here:
    http://www.murga-linux.com/puppy/viewtopic.php?t=95202


    ReplyDelete
  23. Has anyone created a deobfuscated version of Skypekit?

    ReplyDelete
    Replies
    1. yes. search for 2012 skype users ip leak news :)

      Delete
    2. I'm aware of that but it didn't help me find a deobfuscated skypekit to use :(

      Delete
    3. SkypeKit_sdk+runtimes_370_412.zip
      http://thepiratebay.se/torrent/7190651/

      skype55_59_deobfuscated_binaries (old, not patched)
      http://thepiratebay.se/torrent/7238404/

      Delete
    4. That version of SkypeKit is useless. If you use it you end up with all of your accounts assigned to your IP banned.

      https://github.com/zhovner/Skype-iplookup/

      What people seem to be asking for is a deobfuscated version of skypekit.exe from Trillian that has the version string spoofed so that they can login again.

      Delete
    5. Skypekit is not same thing as Skype, it doesn't contains single string with version.
      It's version field, sent to server, combined from kit version itself, user_serial, user uniqie id and host token. So you cant just find and replace something

      Delete
    6. I think what people were hoping for is a way to change the version filed so that it bypasses the version check that Microsoft are doing. Maybe it's really that simple? That or get SkypeKit to identify itself as the official Skype client instead.

      Microsoft were able to block SkypeKit 4.1.2 easily, but the older version found in Trillian 5.2.0.13 wasn't blocked for over week after eveyrthing else was already blocked. Skype 3.8 also stopped working once all versions of SkypeKit stopped working.

      Delete
    7. http://skype-open-source.blogspot.ru/2014/08/real-gateway-to-skype-network.html
      skypekit now patched too :)

      Delete
    8. Is there any reason 3.8 was patched instead of 4.1.2? Doesn't 4.1.2 have better support?

      Delete
    9. yes. I have already unpacked before 3.7, and 4.1 still have to be unpacked... )

      Delete
  24. 4.2.0.187 exe deobfuscated http://webfile.ru/538f1d18832921cecc1cfaccfb0afbad
    Great!
    What bytes need to changing here in future?

    ReplyDelete
    Replies
    1. Just search in file for string in unicode.

      Delete
    2. The strings plaintext in 4.2.x so you should just need to search for "6.18.0.106".

      Delete
    3. Thanks a lot for this wonderful version.

      And is it possible to get rid of those 2 debug files that are now generated each time I start Skype?
      Their names are:
      debug--.log
      debug--.trace.txt

      If it's not possible to stop creating these files may be there is a way to change the folder where they are created?

      Delete
    4. to turn off logger in 4.2 - change bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF

      Delete
    5. >to turn off logger in 4.2 - change bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF

      Thank you very much! It works!
      But how to change version in the future?

      Delete
    6. Search for ascii 6.18.0 and replace...

      Delete
    7. "change bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF" - can you please advise a correct tool to do it? Never dealt with such things...

      Delete
    8. try WinHex

      Delete
    9. Thank you very much, changing the bytes does the trick.

      Do you by any chance have a patched business version of 4.2 (4.2.32.187) as I prefer it because of the lack of Facebook etc.

      Are you the owner of this blog or related to it in some way? I just ask as I'd like to make a small donation for your efforts with 4.2 which is so much better than the crappy later releases of Skype.

      Delete
    10. To the person that wrote "change bytes 90 90 90 90 90 90 to 90 E9 71 01 00 00 at offset C15CAF" - can you please advise a correct tool to do it? Never dealt with such things..."

      If you get stuck leave an email address on here (in a way that it can't be trawled) and I'll send you a zipped or rar copy of my amended .exe which works fine after making the changes.

      Delete
    11. Thanks a lot
      Finally there are no log-files.

      PS: I already found WinHex before posting previos question about the tool but it was unable to save files larger than 200K. But after you said that WinHex is a right tool to do it I found the correct WinHex :)

      Thans one more time

      Delete
    12. "To the person that wrote..." - thanks for your help and readiness to help!
      Just done it half an hour ago

      Delete
  25. skype38i_patched.exe
    magnet:?xt=urn:btih:M5PKMUXGE2E5UDA7FCVLEJBEASS7PKAP

    ReplyDelete
    Replies
    1. Thank you very much. It works, and now it is as before!!

      Delete
    2. I have been using this version since a few days now, and it is working perfectly. 3.8 has a clean and simple interface, and it is the only version I know of, with which I can type accents in chat with key combinations. I have one question.Contact group [favorites] tends to multiply while in use.The original version was doing this, Is it possible to fix it? Or, is it only me?

      Delete
    3. Thank you!

      Delete
  26. Hi,

    Can anyone help me out with a patched login version of 6.2.32.106 please?

    This was the last version released before Skype forced hd webcam on all users so 4:3 webcams became practically useless. I have a very good 4:3 webcam and don't want to be forced into buying a new hd cam just to please Microsoft!

    I have the original .exe and just need it patched if it's possible.

    I tried to download some of the patched .exe files listed on here just to see if they worked but my service provider is blocking the links (pirate bay especially) so I'm not sure if any patching will work but I'm very willing to try it if someone can help me patch my file.

    Thanks...Colin

    ReplyDelete
    Replies
    1. Please, help make this version :(

      Delete
    2. I'll do when I have time...

      Delete
  27. Hello! Help! Really need a link to Skype 3.8 !!!
    Please send to vipstar95r@gmail.com

    ReplyDelete
    Replies
    1. skype38i_patched.exe
      magnet:?xt=urn:btih:M5PKMUXGE2E5UDA7FCVLEJBEASS7PKAP

      Delete
  28. skype38i_patched.exe
    magnet:?xt=urn:btih:M5PKMUXGE2E5UDA7FCVLEJBEASS7PKAP

    ReplyDelete
    Replies
    1. Thanks,3.8 is working perfectly.
      But have a question: what is the reason for patch at offset 761390 and 761396? The patch at offset A18082 being the version.

      Delete
    2. It's new supernode ip address. old ones in 3.8 are not online already

      Delete
    3. Спасибо!!! Очень выручили!!!!
      Skype 3.8 отлично работает!!!!
      Ещё научилась пользоваться Торонтом!!!!

      Delete
  29. i-'-m looking for Skype 6.18.64 deobfuscated, liked new chat ui

    ReplyDelete
    Replies
    1. 6.18 still working "as is", for what u need deobsfucated version?

      Delete
  30. Hi Anyone!

    Skype 3.8 Portable (Login Fixed) direct link
    https://rio.by/skype38i_patched.exe

    Skype 4.2 Portable (Login Fixed) direct link
    https://rio.by/skype42i_patched.exe

    Skype 5.5 Portable (Login Fixed) direct link
    https://rio.by/skype55_patched.exe

    Skype 5.9 Portable (Login Fixed) direct link
    https://rio.by/skype59_patched.exe

    ReplyDelete
    Replies
    1. Спасибо!!!!!!!!!!!!

      Delete
    2. With these versions of Skype, it is impossible to enter in public chatrooms that have been created with the new version of Skype. How to solve this problem, anyone to know?

      C этими версиями скайпа не получается войти в чаты, которые были созданы новыми версиями скайпа. Может кто знает как решить эту проблему?

      Delete
    3. Maybe need version more 6.0

      Delete
    4. These versions creates a profile folder in %APPDATA%... Could anyone please tell, how to make it completely portable? (when the app is just unpacks in parent folder and creates a profile folder near it... ) Is there any command line key for it?

      Delete
    5. Skype.exe /datapath:"Data" /removable

      Delete
    6. Thank you very much, Anonymous! For patches and for the reply!

      Delete
    7. I tried both the 4.2 and the 3.8 versions. Neither allowed me to log in. Any ideas why this might be? Do I need to uninstall the previous versions of Skype first?

      Delete
  31. Hi all. I am really fond of version 5.3.0.116 (link to exe https://www.dropbox.com/s/jmfzp5vex8rwsxk/Skype.exe?dl=0 ). I would try deobfuscating and patching it myself, because for reasons already stated doing a simple hex edit on the version number wasn't enough here. However, I am incapable of dreaming in code and I can't seem to find a good tutorial to do it myself.

    If you would be kind enough to patch it for me, I would appreciate it very much, but if you are too busy, just point me to a good tutorial so I (and anyone else reading this) don't have to keep asking "Please do version x.xx.x.xxx".

    ReplyDelete
    Replies
    1. 5.3 still not have deobfuscated version. And remove deobfuscation is hardcore task even for heavy experienced profy.

      Delete
  32. Can somebody patch version 5.7 if it is possible and put it here please?
    Может ли кто нибудь пропатчить версию 5.7, если это возможно, и выложить здесь пожалуйста?

    ReplyDelete
  33. Can somebody patch version 5.10 if it is possible and put it here please?
    Может ли кто нибудь пропатчить версию 5.10, если это возможно, и выложить здесь пожалуйста?

    ReplyDelete
    Replies
    1. For 5.7 and 5.10 versions why don't you use the Skype 5.9.66.114 already available here?

      I'm using 5.9 and it's no different to the requested versions (except for an odd security fix that doesn't bother me.)

      Give it a try you have nothing to lose.

      Delete
    2. Different poster here. 5.9.66.114 is not the same as 5.10. It doesn't have the favorites feature which is the only good addition in newer versions. Also requesting 5.10 if possible, please.

      Delete
  34. thank u sooooooooooooooooooo much !!!!!

    thank u soooooooooooooooooooooo much!!

    ReplyDelete
  35. With these versions of Skype, it is impossible to enter in public chatrooms that have been created with the new version of Skype. How to solve this problem, anyone to know?

    C этими версиями скайпа не получается войти в чаты, которые были созданы новыми версиями скайпа. Может кто знает как решить эту проблему?

    ReplyDelete
  36. Hi everyone. I confirm the version 3.8 from the comments above works fine and I was able to log in and see my contacts. Thank you guys very much for it.

    Before downloading it, I tried to patch Skype myself. I've downloaded the freeware program called HxD (http://mh-nexus.de/en/hxd/) and loaded the executable. I searched for 3.8.0.154 (my version number) and replaced that with 6.9.0.105. I saved the executable and doubleclicked it but I got the alert saying it was corrupted. What did I miss?

    Also, it seems the latest version now is 6.20.0.104, but I couldn't insert that in the spots predefined for my existing version because "8" (in 3.8) is one digit and "20" (in 6.20) has two digits, how should I go about editing that? When I tried to insert 20 the whole offset moved and it showed me an alert saying that the file size might change.

    Please help. Thanks again!

    ReplyDelete
    Replies
    1. You can't patch the original skype.exe because it's protected with special compression techniques and if you mess with those and change the file size you just corrupt the whole thing.

      You can change the deobfuscation version though because that one isn't protected and the resulting .exe is hence much larger than the original skype.exe.

      As for changing the version number you don't need to because the 3.8 that you are using I assume is patched to login as 6.18.0.105 and whilst that version is still supported it will continue to login (unless Microsoft find a way to block the deobfuscation .exe) You only need to change the deobfuscation .exe if 6.18.0.105 gets dropped by skype.

      I'm still learning about deobfuscation so I think I'm right about this but if not will someone please correct me? Thanks.

      Delete
  37. it seem the patched 3.8 is not more working for skype have close my account even if i create in 6.18 version please guys tell me what to do and which version to use

    ReplyDelete
    Replies
    1. It is still working

      Delete
    2. I tried both the 4.2 and the 3.8 versions downloaded via bittorrent. Neither allowed me to log in. Any ideas why this might be? Do I need to uninstall the previous versions of Skype first?

      Delete
  38. Guys anyone can help me, with version 3.8, when i try read the logs is impossible all is encoded. P.D: I'm try to make a SkypeResolver and i need a good version...

    ReplyDelete
    Replies
    1. You need deobsfucated version, with patch for no log encryption

      Delete
    2. Anyone can give me the "no log encryption" version?

      Delete
  39. спасибо что вы есть)
    скачал 55 пропатченный - все работает.
    а можно ли 4.2.0.169 тоже пропатчить? привык к нему.. :(

    ReplyDelete
  40. 3.8 version is not working :( Any new fix ?

    ReplyDelete
  41. 3.8 version working! Спасибо!

    ReplyDelete
  42. skype42i_patched.exe creates two debug text files. Can you fix that issue, please?

    ReplyDelete
  43. Look guys !! It’s not working !! http://i.imgur.com/rmGDKJS.jpg this is what i get ?! how do u make this patch work ?! please answer.. :(

    ReplyDelete
  44. Hello!
    Please unpack this 5.10 version:
    http://d-h.st/xi8
    Thanks!

    ReplyDelete
  45. В ехешниках 4.2 версии нет такой строки C15CAF
    Помогите.

    There is no C15CAF in exe file 4.2

    ReplyDelete
  46. Latest version of skype59_patched.exe has been blocked, unable to login now.

    ReplyDelete
    Replies
    1. With patched 4.2, I just signed out for testing. I was able to sign in again.
      So, 4.2 works.

      Delete
  47. Hi all, version 4.2.0.187 working for me, but i need help with version 4.2.0.169. Pleas, patch this version.

    EXE File is pack to zip here:
    http://www.filedropper.com/skype-420169-exe
    or
    http://s000.tinyupload.com/index.php?file_id=37780111072861776785
    or
    http://www71.zippyshare.com/v/10137901/file.html

    Thank you very much for help. Thanks seriously ...

    ReplyDelete